سلام وقتی فرمان Apt-get install -f رو وارد میکنم با خطای زیر رو به رو میشوم لطفا اگر کسی اطلاعاتی در این زمینه برای رفع ارور دارد کمکم کند

کد HTML:
apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 aptitude:i386 : Depends: libapt-pkg4.12:i386 (>= 0.8.16~exp12ubuntu6) but it is not installable
                 Depends: libboost-iostreams1.46.1:i386 (>= 1.46.1-1) but it is not installable
                 Depends: libc6:i386 (>= 2.4) but it is not installable
                 Depends: libcwidget3:i386 but it is not installable
                 Depends: libept1.4.12:i386 but it is not installable
                 Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installable
                 Depends: libncursesw5:i386 (>= 5.6+20070908) but it is not installable
                 Depends: libsigc++-2.0-0c2a:i386 (>= 2.0.2) but it is not installable
                 Depends: libsqlite3-0:i386 (>= 3.6.5) but it is not installable
                 Depends: libstdc++6:i386 (>= 4.6) but it is not installable
                 Depends: libtinfo5:i386 but it is not installable
                 Depends: libxapian22:i386 but it is not installable
                 Recommends: apt-xapian-index:i386 but it is not installable
                 Recommends: libparse-debianchangelog-perl:i386 but it is not installable
 aptitude-common : Recommends: aptitude but it is not installable
                   Breaks: aptitude:i386 (< 0.6.8-1) but 0.6.6-1ubuntu1 is installed
 perl : Depends: perl-base (= 5.20.1-1) but 5.20.2-6 is installed
        Recommends: rename but it is not installable
 perl-base : PreDepends: dpkg (>= 1.17.17) but 1.17.13ubuntu1 is installed
             Breaks: perl (< 5.20.2~) but 5.20.1-1 is installed
             Breaks: perl-modules (< 5.20.2~) but 5.20.1-1 is installed
             Breaks: perl-modules:i386 (< 5.20.2~)
 ppa-purge : Depends: aptitude but it is not installable
 tasksel : Depends: aptitude (>= 0.2.15-1) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies