]> [حل شد] نصب نشدن ssh در اوبونتو
صفحه 1 از 2 12 آخرینآخرین
نمایش نتایج: از 1 به 10 از 12

موضوع: نصب نشدن ssh در اوبونتو

  1. Top | #1
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Dec 2014
    شماره عضویت
    447
    نوشته ها
    84
    OS/Browser
    Windows NT/Windows 8.1 10.0 Chrome 46.0.2490.71

    نصب نشدن ssh در اوبونتو

    سلام
    یک اوبونتو ubuntu-12.04.5-server-i386.iso از آدرس اصلی Ubuntu 12.04.5 LTS (Precise Pangolin) نصب کردم که موارد زیر نصب نمیشن و نمیتونم به ssh دسترسی داشته باشم در resolv.conf هم دی ان اس گوگل ست شده و به گوگل ping میده مشکلی هم نداره

    E: unable to correct problem, you have help broken packages یا میگه از help استفاده کن

    sudo apt-get install ssh

    sudo apt-get install openssh-server

    باتشکر

  2. Top | #2
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 41.0
    سلام.
    برای چی سرور نصب میکنید!؟ سرور برای استفاده روی سرور هست نه استفاده خانگی. ssh رو روی دسکتاپ هم میتونید نصب کنید.
    به هر حال؛ برای مشکلتون:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-get update ; sudo apt-get autoremove ; sudo apt-get -f install

    box این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

  3. Top | #3
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Dec 2014
    شماره عضویت
    447
    نوشته ها
    84
    OS/Browser
    Windows NT/Windows 8.1 10.0 Chrome 46.0.2490.71
    نقل قول نوشته اصلی توسط S0h3!L نمایش پست ها
    سلام.
    برای چی سرور نصب میکنید!؟ سرور برای استفاده روی سرور هست نه استفاده خانگی. ssh رو روی دسکتاپ هم میتونید نصب کنید.
    به هر حال؛ برای مشکلتون:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-get update ; sudo apt-get autoremove ; sudo apt-get -f install

    سهیل جان دارم تست میزنم رو نسخه های 32 بیتی قبلاً 64 بیتی داشتم الان میخوام به هاستینگ بگم کدومو نصب کنه بره اینه که دارم تست میزنم
    الان مشکل حل نشد مشکل هنوز پابرجاست دوباره همون ارورو میده
    E: unable to correct problem, you have help broken packages

  4. Top | #4
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 41.0
    دستور رو دقیقا همونطوری که گفتم وارد کردید؟
    ارور رو کامل نخوندم، درضمن held هست وسط اون متن نه help
    بعضی پکیج ها hold شدن، یعنی از بروزرسانی یا حذف شدنش جلوگیری میشه... پس حواستون باشه چکار میکنید، ممکنه پکیج هایی که hold شدن دلیلی برای hold شدنشون بوده. (به صورت پیشفرض هیچ پکیجی hold نیست، خودتون با کارهایی که انجام دادید باعث hold شدن بعضی پکیج ها شدید)
    با دستور زیر پکیج هایی که hold شدن رو ببینید:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-mark showhold


    سپس با دستور زیر پکیج هارو از حالت hold دربیارید:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-mark unhold package-mesal esm-package-hold-shode esmpackage-sevom


    میتونید چند پکیج رو با فاصله از این حالت در بیارید اگه چندتا بودن.
    box این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

  5. Top | #5
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Dec 2014
    شماره عضویت
    447
    نوشته ها
    84
    OS/Browser
    Windows NT/Windows 8.1 10.0 Chrome 46.0.2490.71
    نقل قول نوشته اصلی توسط S0h3!L نمایش پست ها
    دستور رو دقیقا همونطوری که گفتم وارد کردید؟
    ارور رو کامل نخوندم، درضمن held هست وسط اون متن نه help
    بعضی پکیج ها hold شدن، یعنی از بروزرسانی یا حذف شدنش جلوگیری میشه... پس حواستون باشه چکار میکنید، ممکنه پکیج هایی که hold شدن دلیلی برای hold شدنشون بوده. (به صورت پیشفرض هیچ پکیجی hold نیست، خودتون با کارهایی که انجام دادید باعث hold شدن بعضی پکیج ها شدید)
    با دستور زیر پکیج هایی که hold شدن رو ببینید:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-mark showhold


    سپس با دستور زیر پکیج هارو از حالت hold دربیارید:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-mark unhold package-mesal esm-package-hold-shode esmpackage-sevom


    میتونید چند پکیج رو با فاصله از این حالت در بیارید اگه چندتا بودن.
    این دستورو زدم چیزی نیومد

    sudo apt-mark showhold
    کلاً همه چیز دیفالته من به چیزی دست نزدم
    دوتا ورژن 34 بیتی از سایت اصلی اوبونتو دانلود کردم و این مشکلات بوجود اومد
    ویندوز مورد استفاده من ویندوز 10 مجازی ساز vmware workstation 12 Pro

    در رابطه با این مطلب این سایت رو پیدا کردم و این توضیحات درش داده شده میشه کمکم کنید ؟

    https://developer.valvesoftware.com/wiki/SteamCMD

    Debian based distributions (Ubuntu, Mint, etc.)


    sudo apt-get install lib32stdc++6

    Noteia32-libs are not required to install SteamCMD; lib32gcc1 is enough.
    With Debian 7 "Wheezy" you may encounter this error:

    The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-multiarch but it is not installable

    E: Unable to correct problems, you have held broken packages.

    To fix this, do the following:

    dpkg --add-architecture i386
    apt-get update
    apt-get install lib32gcc1



    اینم سایتی هست که در مورد لینوکسه که انتهای همین صفحه لینک شده بود

    https://wiki.archlinux.org/index.php/Multilib
    ویرایش توسط box : 10-20-2015 در ساعت 05:30 AM

  6. Top | #6
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 41.0
    وقتی اروری که قرار دادید میاد یعنی اینکه پکیج های hold شده دارین! چنین چیزی غیرممکنه هیج دستکاری نکرده باشید و این ارور رو بده!

    در رابطه با کدوم مطلب!!؟ اینا برای چیه اصلا!؟ برای مشکل جدید تاپیک جدید بزنید و توش درست همه چیز رو توضیح بدید.
    box این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

  7. Top | #7
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Dec 2014
    شماره عضویت
    447
    نوشته ها
    84
    OS/Browser
    Windows NT/Windows 8.1 10.0 Chrome 46.0.2490.71
    نقل قول نوشته اصلی توسط S0h3!L نمایش پست ها
    وقتی اروری که قرار دادید میاد یعنی اینکه پکیج های hold شده دارین! چنین چیزی غیرممکنه هیج دستکاری نکرده باشید و این ارور رو بده!

    در رابطه با کدوم مطلب!!؟ اینا برای چیه اصلا!؟ برای مشکل جدید تاپیک جدید بزنید و توش درست همه چیز رو توضیح بدید.
    در رابطه با همین تاپیک هست که به دانلود نشدن پکیج ها اشاره کرده با رنگ قرمز مشخصش کردم
    سهیل جان مگه میشه دوتا iso از سایت اصلی اوبونتو دانلود و نصب کنی و این مشکل از جانب من بوجود بیاد ؟
    این مشکل بصورت پیشفرض در دبیان و نسخه هایی که تحت دبیان ساخته شدن وجود داره که در سایت مورد نظر هم بهش اشاره کرده
    اگر میتونید اون دوتا لینک رو برام ترجمه کنی ممنون میشم مخصوصا این لینک رو
    اینم سایتی هست که در مورد لینوکسه که انتهای همین صفحه لینک شده بود

    https://wiki.archlinux.org/index.php/Multilib

  8. Top | #8
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 41.0
    لینک مال آرچ لینوکسه، آرچ توزیعی کاملا متفاوت با اوبونتو و دبین ـه.
    اون یکی لینک هم مال استیم هست (توزیعی برای گیمر ها! :| ) هیچ ربطی به این مشکل نداره و اون دستورهایی هم که کپی کردید هم هیچ ربطی ندارن.
    شما اوبونتو رو نصب کنید و هنگام نصب تنظیم خاصی انجام ندید و درحد ممکن همه چیز رو به صورت پیشفرض بزارید، وقتی نصب شد این دستور رو وارد کنید سپس هر پکیجی که میخواید رو نصب کنید (ssh) ...:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-get update && sudo apt-get upgrade

    box این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

  9. Top | #9
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Dec 2014
    شماره عضویت
    447
    نوشته ها
    84
    OS/Browser
    Windows NT/Windows 8.1 10.0 Chrome 46.0.2490.71
    نقل قول نوشته اصلی توسط S0h3!L نمایش پست ها
    لینک مال آرچ لینوکسه، آرچ توزیعی کاملا متفاوت با اوبونتو و دبین ـه.
    اون یکی لینک هم مال استیم هست (توزیعی برای گیمر ها! :| ) هیچ ربطی به این مشکل نداره و اون دستورهایی هم که کپی کردید هم هیچ ربطی ندارن.
    شما اوبونتو رو نصب کنید و هنگام نصب تنظیم خاصی انجام ندید و درحد ممکن همه چیز رو به صورت پیشفرض بزارید، وقتی نصب شد این دستور رو وارد کنید سپس هر پکیجی که میخواید رو نصب کنید (ssh) ...:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]
    sudo apt-get update && sudo apt-get upgrade

    سهیل جان من الان 3 ماهه که دارم با لینوکس رو سرور وافعی کار میکنم و نصب دبیان و سنت او اس رو انجام دادم منتها تاحالا اوبونتو رو انجام نداده بودم بره همین نمیدونستم که این مشکل هست تو اون سایت گیم هم که میگید بهش اشاره کرده
    حالا من میخوام از دوتا لینک 1 و 2 اوبونتو 14 سرور دانلود کنم فقط بگید که فرق Utopic Unicorn با ( Ubuntu 14.04.1 LTS (Trusty Tahr چی هست
    اینارو نصب کنم ببینم اینام بصورت دیفالت مشکل دارن یا نه
    باتشکر

  10. Top | #10
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 41.0
    utopic نسخه ۱۴.۱۰ هست، trusty نسخه ۱۴.۰۴.
    شما ۱۴.۰۴ سرور رو دانلود کنید:
    http://releases.ubuntu.com/14.04.3/u...rver-amd64.iso
    box این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

صفحه 1 از 2 12 آخرینآخرین

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

کلمات کلیدی این موضوع

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •