]> [حل شد] راهنمای نصب regressiontests-5.0
صفحه 1 از 3 123 آخرینآخرین
نمایش نتایج: از 1 به 10 از 24

موضوع: راهنمای نصب regressiontests-5.0

  1. Top | #1
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Sep 2014
    شماره عضویت
    323
    نوشته ها
    20
    OS/Browser
    Windows 7 MS Internet Explorer 10.0

    راهنمای نصب regressiontests-5.0

    با سلام خدمت دوستان عزیز من برای نصب برنامه gromacs به مشکل برخورد کردم چون ناز به نصب برنامه regressiontests-5.0 دارد .از دوستان اگه کسی میدونه چزور میتونم اینو نصب کنم مماون میشم کمک کنه. cmake .. -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON

  2. Top | #2
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 32.0
    سلام.
    توی مخزن اصلیش این پکیج موجود هست:
    https://github.com/gromacs
    yaser این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

  3. Top | #3
    :(){ :|:& };:
     

    عنوان کاربر
    مدیر بخش
    تاریخ عضویت
    May 2014
    شماره عضویت
    168
    نوشته ها
    196
    OS/Browser
    Linux (Ubuntu) Chromium 37.0.2062.94
    نقل قول نوشته اصلی توسط yaser نمایش پست ها
    با سلام خدمت دوستان عزیز من برای نصب برنامه gromacs به مشکل برخورد کردم چون ناز به نصب برنامه regressiontests-5.0 دارد .از دوستان اگه کسی میدونه چزور میتونم اینو نصب کنم مماون میشم کمک کنه. cmake .. -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON
    هزارتا مشکل میتونه بوجود بیاد.
    حداقل خطا رو بگو تا شاید بتونیم کمکت کنیم.
    حالا که از سورس کامپایل میکنی ۵.۰.۱ رو نصب کن.
    yaser این پست را پسندیده است! :)

  4. Top | #4
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Sep 2014
    شماره عضویت
    323
    نوشته ها
    20
    OS/Browser
    Linux (Ubuntu) Firefox 32.0
    نقل قول نوشته اصلی توسط S0h3!L نمایش پست ها
    سلام.
    توی مخزن اصلیش این پکیج موجود هست:
    https://github.com/gromacs
    ممنون از جوابتون چطور می تونم این بسته رو نصب کنم یعنی این regressiontests-5.0 یعنی خودش به صورت خودکار باید نصب بشه چون به صورت خودکار نصب نمیشه.

    - - - Updated - - -

    نقل قول نوشته اصلی توسط Milux نمایش پست ها
    هزارتا مشکل میتونه بوجود بیاد.
    حداقل خطا رو بگو تا شاید بتونیم کمکت کنیم.
    حالا که از سورس کامپایل میکنی ۵.۰.۱ رو نصب کن.
    خدمت شما اینم تمام ارورها در ضمن من این بسته رو که تقریبا حدود ۳۴۰ مگابایت هستش رو داونلود و نصب کردمCUDA دیگه نمی دونم چرا بازم داره ارور میده.و همچنین اخرین ورژن برنامه cmake and fftw رو که نیاز بود نصب کردم دیگه نمیدونم مشکل کچاست:
    yaser@yaser-HP-Pavilion-15-Notebook-PC:~/Downloads/gromacs-5.0/build$ cmake '/home/yaser/Downloads/gromacs-5.0' cmake .. -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON
    -- Could NOT find CUDA (missing: ) (found suitable version "5.5", minimum required is "4.0")
    -- Could NOT find LibXml2 (missing: LIBXML2_LIBRARIES LIBXML2_INCLUDE_DIR)
    CMake Warning at src/contrib/fftw/CMakeLists.txt:79 (message):
    The GROMACS build will download FFTW 3.3.3 as requested, but it will not
    know the file it receives is correct. If you now use

    make

    GROMACS will build and link to FFTW anyway, but there is a possible security risk if you execute a GROMACS tool that calls this library. Instead, you can use

    make fftwBuild

    to do just the download and build of FFTW, and then run

    md5sum src/contrib/fftw/fftwBuild-prefix/src/fftw-3.3.3.tar.gz

    to see if it matches 0a05ca9c7b3bfddc8278e7c40791a1c2. If so, everything
    is OK and you should use

    make

    to proceed with the rest of the GROMACS build. Alternatively, you could stop using GMX_BUILD_OWN_FFTW, and instead follow the GROMACS installation instructions to build FFTW yourself.


    -- The GROMACS-managed build of FFTW 3 will configure with the following optimizations: --enable-sse2
    -- Could NOT find Pandoc (missing: PANDOC_EXECUTABLE)
    Downloading: http://gerrit.gromacs.org/download/r...sts-5.0.tar.gz
    -- [download 0% complete]
    CMake Error at tests/CMakeLists.txt:58 (message):
    error: downloading
    'http://gerrit.gromacs.org/download/regressiontests-5.0.tar.gz' failed

    status_code: 1

    status_string: "unsupported protocol"

    log: About to connect() to gerrit.gromacs.org port 80 (#0)

    Trying 130.237.25.133... connected

    Connected to gerrit.gromacs.org (130.237.25.133) port 80 (#0)

    GET /download/regressiontests-5.0.tar.gz HTTP/1.1

    User-Agent: curl/7.16.1

    Host: gerrit.gromacs.org

    Accept: */*



    HTTP/1.1 302 Found

    Date: Wed, 24 Sep 2014 144404 GMT

    Server: Apache/2.2.22 (Ubuntu)

    Location: https://kth.box.com/shared/static/lu...l0b85ghkso4.gz

    Vary: Accept-Encoding

    Content-Length: 325

    Content-Type: text/html; charset=iso-8859-1

    Connection: close

    Closing connection #0

    Issue another request to this URL:
    'https://kth.box.com/shared/static/luuzstykml0b85ghkso4.gz'

    libcurl was built with SSL disabled, https: not supported!

    unsupported protocol



    -- Configuring incomplete, errors occurred!
    See also "/home/yaser/Downloads/gromacs-5.0/build/CMakeFiles/CMakeOutput.log".
    See also "/home/yaser/Downloads/gromacs-5.0/build/CMakeFiles/CMakeError.log".
    yaser@yaser-HP-Pavilion-15-Notebook-PC:~/Downloads/gromacs-5.0/build$

    بعد که فولدر build دو حذف می کنم و دوباره می سازم که نصب کنم این ارور رو میده که مربوط به اینه:

    Downloading: http://gerrit.gromacs.org/download/r...sts-5.0.tar.gz
    -- [download 0% complete]
    CMake Error at tests/CMakeLists.txt:58 (message):
    error: downloading
    'http://gerrit.gromacs.org/download/regressiontests-5.0.tar.gz' failed

    status_code: 1

    status_string: "unsupported protocol"

    log: About to connect() to gerrit.gromacs.org port 80 (#0)

    Trying 130.237.25.133... connected

    Connected to gerrit.gromacs.org (130.237.25.133) port 80 (#0)

    GET /download/regressiontests-5.0.tar.gz HTTP/1.1

    User-Agent: curl/7.16.1

    Host: gerrit.gromacs.org

    Accept: */*



    HTTP/1.1 302 Found

    Date: Wed, 24 Sep 2014 14:56:16 GMT

    Server: Apache/2.2.22 (Ubuntu)

    Location: https://kth.box.com/shared/static/lu...l0b85ghkso4.gz

    Vary: Accept-Encoding

    Content-Length: 325

    Content-Type: text/html; charset=iso-8859-1

    Connection: close

    Closing connection #0

    Issue another request to this URL:
    'https://kth.box.com/shared/static/luuzstykml0b85ghkso4.gz'

    libcurl was built with SSL disabled, https: not supported!

    unsupported protocol



    -- Configuring incomplete, errors occurred!
    See also "/home/yaser/Downloads/gromacs-5.0/build/CMakeFiles/CMakeOutput.log".
    See also "/home/yaser/Downloads/gromacs-5.0/build/CMakeFiles/CMakeError.log".
    yaser@yaser-HP-Pavilion-15-Notebook-PC:~/Downloads/gromacs-5.0/build$


    ویرایش توسط yaser : 09-24-2014 در ساعت 06:56 PM

  5. Top | #5
    R+L=J
     

    عنوان کاربر
    مدیریت کل سایت
    تاریخ عضویت
    Jun 2013
    شماره عضویت
    1
    نوشته ها
    2,225
    نوشته های وبلاگ
    1
    OS/Browser
    Linux (Ubuntu) Firefox 32.0
    این متن هارو داخل بی بی کد [code] قرار بدید عزیز.
    ممنون از جوابتون چطور می تونم این بسته رو نصب کنم یعنی این regressiontests-5.0 یعنی خودش به صورت خودکار باید نصب بشه چون به صورت خودکار نصب نمیشه.
    شما مگه با git نصب نمیکنید!؟
    yaser این پست را پسندیده است! :)
    قوانین (همه کاربران مطالعه کنند) : http://www.ubuntuforums.ir/thread1.html
    لطفا پس از حل مشکل یا رسیدن به جوابتون:
    di LKI3 ۲.۱۷. همه کاربران موظفند پس از حل شدن مشکل یا رسیدن به جواب خود، تاپیکشان را به عنوان موضوع حل شده نشانه‌گذاری کنند.
    برای اینکار، از منوی بالا تاپیک، منو "ابزار‌های موضوع" را انتخاب کرده و سپس گزینه "نشانه‌گذاری این تاپیک به عنوان موضوع حل شده" را انتخاب کنید. این تصویر را ببینید: http://www.imgshare.ir/di-TNWC.png

    rlj3 they will rule together small

  6. Top | #6
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Sep 2014
    شماره عضویت
    323
    نوشته ها
    20
    OS/Browser
    Linux (Ubuntu) Firefox 32.0
    نقل قول نوشته اصلی توسط S0h3!L نمایش پست ها
    این متن هارو داخل بی بی کد [code] قرار بدید عزیز.

    شما مگه با git نصب نمیکنید!؟
    من از طریق ترمبنال اینارو نصب میکنم .و با عرض بوزش من نمیدونم git چیه؟من حدود ۱ ماهه دارم با اوبونتو کار می کنم.

  7. Top | #7
    :(){ :|:& };:
     

    عنوان کاربر
    مدیر بخش
    تاریخ عضویت
    May 2014
    شماره عضویت
    168
    نوشته ها
    196
    OS/Browser
    Linux (Ubuntu) Chromium 37.0.2062.94
    نقل قول نوشته اصلی توسط yaser نمایش پست ها
    من از طریق ترمبنال اینارو نصب میکنم .و با عرض بوزش من نمیدونم git چیه؟من حدود ۱ ماهه دارم با اوبونتو کار می کنم.
    خب زیاد عجله نکن گیت هم یاد میگیری (:من نسخه ۵.۰.۱ رو تست کردم و رفت برای دانلود و دیگه حوصله ش نبود و کنسلش کردم. این نسخه رو تست کن احتمالا جواب بده.
    کد:
    -- Looking for inttypes.h - found-- Performing Test HAS_NO_UNUSED_PARAMETER-- Performing Test HAS_NO_UNUSED_PARAMETER - Success-- Performing Test HAS_NO_DEPRECATED_REGISTER-- Performing Test HAS_NO_DEPRECATED_REGISTER - SuccessDownloading: http://gerrit.gromacs.org/download/regressiontests-5.0.1.tar.gz-- [download 0% complete]-- [download 1% complete]^C
    ویرایش توسط Milux : 09-24-2014 در ساعت 07:13 PM

  8. Top | #8
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Sep 2014
    شماره عضویت
    323
    نوشته ها
    20
    OS/Browser
    Linux (Ubuntu) Firefox 32.0
    نقل قول نوشته اصلی توسط Milux نمایش پست ها
    خب زیاد عجله نکن گیت هم یاد میگیری (:من نسخه ۵.۰.۱ رو تست کردم و رفت برای دانلود و دیگه حوصله ش نبود و کنسلش کردم. این نسخه رو تست کن احتمالا جواب بده.
    کد:
    -- Looking for inttypes.h - found-- Performing Test HAS_NO_UNUSED_PARAMETER-- Performing Test HAS_NO_UNUSED_PARAMETER - Success-- Performing Test HAS_NO_DEPRECATED_REGISTER-- Performing Test HAS_NO_DEPRECATED_REGISTER - SuccessDownloading: http://gerrit.gromacs.org/download/regressiontests-5.0.1.tar.gz-- [download 0% complete]-- [download 1% complete]^C
    ممنون ولی من اینو دانلود کردم نمی دونم چطور نصبش کنم رو اوبونتو.در ضمن من git رو دانلود کردم حرور ۵۵۰ مگابایت بود و حالا با دستور sudo apt-get install git نصبش کنم یا اول باید از حالت زیپ در بیارم و بعد از یک روش دیگه نصب کنم؟؟؟

    بازم عذر می خوام که زیاد سوال میپرسم.ممنون از پاسختون.

  9. Top | #9
    :(){ :|:& };:
     

    عنوان کاربر
    مدیر بخش
    تاریخ عضویت
    May 2014
    شماره عضویت
    168
    نوشته ها
    196
    OS/Browser
    Linux (Ubuntu) Chromium 37.0.2062.94
    گیت رو که میتونی از مخازن نصب کنی (با همون دستوری که خودت نوشتی). در کل همیشه سعی کن برنامه ها رو از مخازن نصب کنی و اگه توی مخازن رسمی نبود اون وقت برو سراغ باینری هایی که موجوده یا در نهایت کامپایل سروس.

    طبق راهنماش اینطوری باید نصب شه:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]

    tar xfz gromacs-5.0.1.tar.gz
    cd gromacs-5.0.1
    mkdir build
    cd build
    cmake .. -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON
    make
    make check
    sudo make install
    source /usr/local/gromacs/bin/GMXRC


  10. Top | #10
    لطفا استاتوس خود را تنظیم کنید.
     

    عنوان کاربر
    کاربر سایت
    تاریخ عضویت
    Sep 2014
    شماره عضویت
    323
    نوشته ها
    20
    OS/Browser
    Linux (Ubuntu) Firefox 32.0
    نقل قول نوشته اصلی توسط Milux نمایش پست ها
    گیت رو که میتونی از مخازن نصب کنی (با همون دستوری که خودت نوشتی). در کل همیشه سعی کن برنامه ها رو از مخازن نصب کنی و اگه توی مخازن رسمی نبود اون وقت برو سراغ باینری هایی که موجوده یا در نهایت کامپایل سروس.

    طبق راهنماش اینطوری باید نصب شه:

    دستور لینوکس:

    UbuntuForums.ir@Linux:~$

    [انتخاب دستورات]

    tar xfz gromacs-5.0.1.tar.gz
    cd gromacs-5.0.1
    mkdir build
    cd build
    cmake .. -DGMX_BUILD_OWN_FFTW=ON -DREGRESSIONTEST_DOWNLOAD=ON
    make
    make check
    sudo make install
    source /usr/local/gromacs/bin/GMXRC

    دقیقا همینه وقتی نصب می کنم به این صورت هممون ارورهایی که بالا قرار دادم رو میده و من تنها مشکلم طریقه نصب regressiontests-5.0.1 که اگه نصب بشه دیگه مشکلی ندارم.

صفحه 1 از 3 123 آخرینآخرین

اطلاعات موضوع

کاربرانی که در حال مشاهده این موضوع هستند

در حال حاضر 1 کاربر در حال مشاهده این موضوع است. (0 کاربران و 1 مهمان ها)

کلمات کلیدی این موضوع

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •